Delays with emails for confirmation codes or account verification

Incident Report for Artera

Resolved

Artera's partners are no longer experiencing any issues or delays with sending emails.

We thank you for your patience and understanding.

If you have any questions or are still experiencing issues, please reach out to our support team via support.artera.io.
Posted Apr 23, 2025 - 21:56 PDT

Monitoring

Our email delivery partner has mitigated the issue and are reporting that e-mail traffic is now working 100% with all checks.They continue to monitor the situation closely and more information will be available soon.

For additional information on the incident, please see:
https://status.sendgrid.com/

If you have any other related issues to report, please reach out to our support team via support.artera.io.
Posted Apr 23, 2025 - 17:38 PDT

Identified

Artera has been made aware an issue identified by our email delivery partner that may impact logging into the Artera application.
You may experience a delay in confirmation codes or verification links delivered via email.

We will continue to monitor the situation and provide updates as soon as more information becomes available.

For additional information on the incident, please see:
https://status.sendgrid.com/

If you have any other related issues to report, please reach out to our support team via support.artera.io.
Posted Apr 23, 2025 - 15:09 PDT
This incident affected: USA - Artera Platform (Login to Artera Web App).