AWS US-East-1 outage, Impacting Multiple Services

Incident Report for Artera

Resolved

All Artera systems are operational at this time following the outage AWS experienced on 10/20/2025.

Messages and Automations are sending as expected.

We thank you for your patience as we worked through this issue. If you have any questions or related issues to report, please reach out to our support team via support.artera.io.
Posted Oct 20, 2025 - 23:33 PDT

Update

We're observing that all Artera systems are operational at this time following the outage AWS experienced this morning.

Artera Analytics are experiencing long load times and time outs because of AWS's ongoing incident.

Messages and Automations are sending as expected.

We are continuing to monitor the stability of our services as AWS recovers fully.

We thank you for your patience as we continue to work through this issue. If you have any questions or related issues to report, please reach out to our support team via support.artera.io.
Posted Oct 20, 2025 - 14:29 PDT

Update

We're observing that all Artera systems are operational at this time following the outage AWS experienced this morning.

Artera Analytics are experiencing long load times and time outs because of AWS's ongoing incident.

Messages and Automations are sending as expected.

We are continuing to monitor the stability of our services as AWS recovers fully.

We thank you for your patience as we continue to work through this issue. If you have any questions or related issues to report, please reach out to our support team via support.artera.io.
Posted Oct 20, 2025 - 09:07 PDT

Monitoring

We're observing that all Artera systems are operational at this time following the outage AWS experienced this morning.

Messages and Automations are sending as expected.

We are continuing to monitor the stability of our services as AWS recovers fully.

We thank you for your patience as we continue to work through this issue. If you have any questions or related issues to report, please reach out to our support team via support.artera.io.
Posted Oct 20, 2025 - 07:06 PDT

Update

While core Artera systems remain operational following the earlier AWS event, we have identified an elevated rate of messaging failures.

We are actively working with our telecoms partner to immediately identify and resolve these message failures related to the ongoing AWS service degradation.

We apologize for this continued disruption and will provide updates via this status page as they become available.

If you have urgent questions, please reach out to our support team via support.artera.io.
Posted Oct 20, 2025 - 06:47 PDT

Update

We're observing that all Artera systems are operational at this time following the outage AWS experienced this morning.

Messages and Automations are sending as expected.

We are continuing to monitor the stability of our services as AWS recovers fully.

We thank you for your patience as we worked through this issue. If you have any questions or related issues to report, please reach out to our support team via support.artera.io.
Posted Oct 20, 2025 - 05:49 PDT

Identified

We are seeing partial recovery and are scaling systems to handle the influx of traffic. However we are still experiencing outages across multiple product lines due to an ongoing AWS incident( https://health.aws.amazon.com/health/status ) with their US1 Region.
Posted Oct 20, 2025 - 03:41 PDT

Investigating

Artera is currently investigating reports of an issue with outages across multiple product lines due to an ongoing AWS incident( https://health.aws.amazon.com/health/status ) with their US1 Region. Twilio has activated their incident response team and have all hands on deck working on remediation. They are partnering directly with AWS on the incident and have also escalated to their leadership.

While we do not have an ETA for a resolution, we are actively investigating and will provide updates here.
We thank you for your patience as we continue to look into this issue.
If you have any other related issues to report, please reach out to our support team via support.artera.io.
Posted Oct 20, 2025 - 02:52 PDT
This incident affected: USA - Messaging (Automations and Automated Messaging, Manual Messaging, SendMessage API), USA - Artera Platform (Analytics and Reporting), USA - Infrastructure and Partners (Vendors and Partners), and CANADA - Infrastructure and Partners (Vendors and Partners).